Incorrect Customer Data
Incident Report for sendwithus
Resolved
The root problem has been resolved. Sendwithus support will be reaching out to impacted customers.
Posted Mar 15, 2023 - 21:36 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2023 - 19:49 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 15, 2023 - 17:18 PDT
Update
We have temporarily disabled the feature while we investigate.
Posted Mar 15, 2023 - 16:01 PDT
Investigating
We are investigating the issue where users are seeing incorrect data in the customer's panel
Posted Mar 15, 2023 - 15:52 PDT
This incident affected: Web Interface.