Email Logs Page Availability Issues

Incident Report for sendwithus

Resolved

This incident has been resolved.
Posted May 23, 2023 - 10:33 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 23, 2023 - 08:02 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 23, 2023 - 07:56 PDT

Investigating

Our engineering team is currently investigating an issue with the Email logs page. Email sending may be delayed.
Posted May 23, 2023 - 07:45 PDT
This incident affected: Web Interface.