Sendwithus Dashboard Issues
Incident Report for sendwithus
Resolved
This incident has been resolved.
Posted Jan 10, 2017 - 13:28 PST
Monitoring
The issue has been found and the dashboard is returning to normal.
Posted Jan 10, 2017 - 10:52 PST
Investigating
Some customers may be experiencing issues with the Sendwithus dashboard. Our engineers are investigating.
Posted Jan 10, 2017 - 10:20 PST