Sendwithus Delivery Delays
Incident Report for sendwithus
Resolved
The issue has been resolved and email delivery speed has returned to normal.
Posted Jan 11, 2017 - 17:40 PST
Investigating
Emails are delivering as normal, but some customers may seem delays around 10 minutes. Our engineers are investigating.
Posted Jan 11, 2017 - 17:25 PST