Minor email delivery delays
Incident Report for sendwithus
Resolved
Email delivery times have returned to normal.
Posted Mar 14, 2017 - 12:06 PDT
Monitoring
Delivery speeds are beginning to return to normal. Our engineers are continuing to monitor.
Posted Mar 14, 2017 - 11:45 PDT
Identified
Some customers may be experiencing delivery delays of up to ten minutes. Sendwithus engineers are investigating.
Posted Mar 14, 2017 - 10:51 PDT