Delivery delays for some users
Incident Report for sendwithus
Resolved
This incident has been resolved.
Posted over 1 year ago. Jun 19, 2018 - 11:01 PDT
Monitoring
The issue has been identified, a solution has been put in place and delivery times are returning to normal.
Posted over 1 year ago. Jun 19, 2018 - 10:46 PDT
Investigating
The Sendwithus engineering team is investigating delivery delays that is affecting some users. Emails sent with Campaigns are unaffected.
Posted over 1 year ago. Jun 19, 2018 - 10:38 PDT
This incident affected: Email Delivery.