Email Delivery Delays
Incident Report for sendwithus
Resolved
This incident has been resolved.
Posted Sep 13, 2016 - 16:59 PDT
Update
Email delivery speed has returned to acceptable levels, we're continuing to monitor.
Posted Sep 13, 2016 - 16:42 PDT
Monitoring
The issue has been resolved and email delivery speeds should return to normal soon.
Posted Sep 13, 2016 - 16:36 PDT
Identified
The issue has been identified, there's a latency issue with an upstream provider. We're trying to get the issue resolved as soon as possible.
Posted Sep 13, 2016 - 16:14 PDT
Investigating
The Sendwithus Engineering team has identified email delivery delays for some customers and are investigating.
Posted Sep 13, 2016 - 15:26 PDT